Common GREET Frequently Asked
Questions (FAQ)

Question Answer

R&D GREET Updates

The R&D GREET model is a publicly accessible model. You can
download the most up-to-date version of the R&D GREET model
at Argonne’s R&D GREET website upon free registration:
https://greet.anl.gov.

1. Selectthe platform of the model you would like to
download on the left-hand side of the screen: R&D
How do | obtain the GREET Excel or R&D GREET .Net.
R&D GREET model? 2. Follow the instructions on the appropriate R&D GREET
Model Platform page
3. For R&D GREET Excel, enter your information and select
Submit.
4. For R&D GREET .Net, install the software and then enter
your information.
Click here for a video tutorial.

Argonne National Laboratory releases annual updates of the
R&D GREET model at Argonne’s R&D GREET website:
https://greet.anl.gov. Sometimes Argonne National Laboratory
releases interim versions of the GREET model (e.g., R&D GREET
2023 Rev. 1) in which the year refers to the year of the GREET
release and Rev. 1 refers to the first interim version.

Yes, you can download older versions of the R&D GREET excel
models at Argonne’s R&D GREET website upon free registration:
https://greet.anl.gov. Once registered, scroll down to the Prior

How often is the R&D
GREET model
updated?

Revisions section. Select the appropriate download link.
For R&D GREET .Net, it is recommended to always use the most
recent version available due to the continuous efforts in

Can | download older
versions of the R&D

GREET model? . o
software bug fix and data file improvement. In case that an older

version of R&D GREET model is needed, please send your
request to greet@anl.gov and discuss with the R&D GREET .Net
development team.




Where can | get
information about CA-
GREET, 45VH2-GREET,

45ZCF-GREET,

40BSAF-GREET, or
adapted versions of
the GREET model?

Please refer to the government body associated with the GREET
versions used for governmental regulatory or incentive
programs. A page for most governmental GREET versions can be
found at the Department of Energy’s GREET website (GREET |
Department of Energy).

How do you cite the
R&D GREET model?

Each R&D GREET version has its own doi, which can be located
on the R&D GREET webpage. You can also cite the “Summary of
Expansions and Updates” documents in the desired citation
format.

Frequent Requests

Where can | learn more
about the R&D GREET
model?

Please visit the GREET publication page
(http://greet.es.anl.gov/publications) for the Model Reports and
the Workshop page (http://greet.es.anl.gov/workshops) for
presentations to become more familiar with the model,
upcoming in-person workshops, and contact information for
certified GREET trainers. You can also refer to the GREET
Tutorials YouTube Channel for video tutorials or the Department
of Energy’s GREET webpage
(https://www.energy.gov/cmei/greet) for more information.

Where can | find an
R&D GREET manual?

For R&D GREET Excel, the most recent manual is available at the
R&D GREET publication page
(http://greet.es.anl.gov/publications). We suggest starting with
the Operating Manual for R&D GREET: Version 1.7, which is out
of date but still useful. On the other hand, comments are
populated inside of R&D GREET and GREET YouTube Channel is
also helpful.

For R&D GREET .Net, the user manual can be accessed through
Menu Bar>"About">"User Manuals".

Where can | find
information about
future R&D GREET
workshops?

Argonne National Laboratory does not have any plans for public
workshops in the near-future; however, Argonne just certified 20
trainers from around the country to conduct R&D GREET
workshops. You can find the nearest in-person R&D GREET
workshop conducted by one of the R&D GREET certified trainers
by visiting the Workshop page
(http://greet.es.anl.gov/workshops).




Where can | find
information about
future R&D GREET
trainings?

Argonne National Laboratory just certified 20 trainers from
around the country to conduct R&D GREET workshops. You can
find contact information for the nearest R&D GREET-certified
trainer by visiting the Workshop page
(http://greet.es.anl.gov/workshops).

Where can | find
information about R&D
GREET tutorials?

For video tutorials on downloading R&D GREET and more, visit
the GREET Tutorials YouTube Channel.

Canyou share the
model code?

At this time, ANL does not share the source codes/passwords
for critical macro functions built in GREET.

Where do | find
supporting documents
for specific pathways?

There are many ways you can locate the supporting documents
and data sources used within the R&D GREET model.

1. Review the comments included throughout the pathway
in R&D GREET Excel. Comments are indicated by purple
flags in the upper right-hand corner of certain cells.

2. Review the notes associated with various pathways in the
R&D GREET. Net model.

3. Referto ANL’'s GREET publication page
(http://greet.es.anl.gov/publications), which includes the
most recent release report for each GREET version,
GREET manuals, technical publications, and
presentations.

4. Email greet@anl.gov with the specific topic area in the
email title for any questions about specific pathways.

Compatibility

What version of Excel
is the R&D GREET
Excel model
compatible with?

R&D GREET Excel is currently known to be compatible with
Excel 2021 and Office 365. Users of older Excel versions should
proceed with caution.

R&D GREET Capabilities

What does the R&D
GREET model do?

The R&D GREET life cycle analysis model allows users to
analyze the energy and emissions impacts of various vehicle
technologies, transportation fuel pathways, energy systems,
materials, and technologies.

What are R&D GREET
outputs?

By evaluating the supply chains of a technology’s life cycle, the
R&D GREET model quantifies the life-cycle total energy use,
fossil energy use, renewable energy use, water consumption, air




pollutant emissions (i.e., volatile organic compound (VOC),
carbon monoxide (CO), nitrogen oxides (NO,), particulate matter
(PM1o or PMas), sulfur oxides (SOx), black carbon (BC), and
organic carbon (OC)) and greenhouse gas emissions (i.e.,
carbon dioxide (CO,), methane (CH,), nitrous oxide (N.O), and
carbon dioxide equivalent (CO.e)).

What can be changed
in R&D GREET?

Each fuel has its own suite of specific inputs the user can
change. Some common inputs include the target year for
simulation, vehicle types and technologies, technology shares
and options, efficiencies, electricity grid region, fossil fuel
production infrastructure, and emission factors. For the R&D
GREET Excel model, these inputs are located on the “Inputs” or
within the “Fuel-specific” tabs and are indicated by yellow or
peach cells. For the R&D GREET .Net model, these inputs can be
found throughout the model in the resources tab, emissions tab,
processes tab, technologies tab, modes tab, vehicles tab and
more.

Common Errors

#Name Error/ Circular
Calculations Error

This error typically occurs in Excel when “lterative Calculations”
are turned off. You will need to go to Excel options and make
sure you enable them. You can do this by selecting File, Options,
and Properties from the upper left-hand corner of the Excel
sheet. In the Calculations options section, check the box
labeled Enable iterative calculation.

Also, the #Name error can occur if you accidentally make an
error in a cell. If this happens, don’t save the model as you
cannot undo the error. Just download a clean version of the
model at https://greet.anl.gov.

If the #Name Error occur immediately after opening the GREET
R&D Excelfile, please try disable automatic calculation in Excel
before opening the R&D GREET file. You can do so by the
following steps:
1. Open ablank workbook.
2. Select Formulas -> Calculation Options -> Manual from
the menu bar.
3. Openthe R&D GREET file.
4. When re-calculation is desired, do one of the following:
a. Selectthe “Results” tab.




b. Press F9.
c. Select Formulas -> Calculate Now from the menu bar.

Macros Error

When you plan to modify R&D GREET, Macros should be
enabled. You can enable Macros by right-clicking on each of the
R&D GREET files, selecting properties, and checking the
unblock option at the bottom of the General tab of the
properties window.

Specific Questions

Why are there
differences between
the results in a journal
article and the relevant
pathway?

The most common reason for this difference is due to using
different versions of R&D GREET with different background
datasets. Already published journal articles might have relied on
previous R&D GREET versions at the time when the publication
were produced. In addition, the results in research papers might
have considered different conditions to present the impact of
various parameters, which may be different from the default
R&D GREET settings.

How do you use the
Stochastic Simulation
tool?

For R&D GREET Excel, you need to go to Windows Excel: Tools>
Add-Ins>, select “Stochastic Simulation” option in the left box
menu, and click OK. Go back to View> Toolbars>, and you
should be able to see the Stochastic Simulation toolbar.

For R&D GREET .Net, please refer to section 5.3 “Stochastic
Simulations” of the user manual through Menu
Bar>"About">"User Manuals".

How can | include my
own forecasts into the
stochastic analysis?

For R&D GREET Excel, please refer to the following link:
https://greet.anl.gov/files/he5am4um.

For R&D GREET .Net, please refer to section 5.3 “Stochastic
Simulations” of the user manual through Menu
Bar>"About">"User Manuals".

How do | change the
fuel economy of
vehicles in R&D
GREET?

For R&D GREET .Net, please refer to section 3.8.8 “Vehicle
Editor” of the user manual through Menu Bar>"About">"User
Manuals".

For R&D GREET Excel:

Before adjusting the fuel economy values, you will want to go to
cell B16 in Inputs sheet and change the value from 1 to 2. For
vehicle fuel economy values, you could enter them in a few
places inside GREET.




The first place is in the time-series tables of the LDT1_TS sheet.
There, you will see a table for each vehicle technology. The table
contains fuel economy and emission rates for baseline
technologies from 1990 to 2050. For new technologies such as
fuel-cell vehicles, the values are relative changes from the
baseline technology to the new technology.

The second place is the Vehicles sheet. You will see
Table/Section 3, where fuel economy and emissions are
presented for all vehicle technologies contained in GREET. Row
72 presents fuel economy values. You can find the cell for fuel-
cell vehicles (e.g., DM72 for gaseous H; FCVs) to enter the
Autonomie-simulated fuel economy value. Emission rates for
vehicle technologies are in Rows 78-95, where you can change
emission rates manually for given technologies.

How does R&D GREET
model carbon
accounting?

The R&D GREET model conducts life-cycle carbon accounting
by tracking all carbon emissions and removals throughout the
entire supply chain of fuel and energy systems from feedstock
production and processing to fuel combustion.

A key aspect of carbon accounting in R&D GREET is the
application of carbon balance principles. For most processes,
CO, emissions are estimated based on the carbon content of
inputs and outputs.

R&D GREET distinguishes between fossil carbon and biogenic
carbon. Fossil carbon originates from geologic sources (e.g.,
petroleum, coal, natural gas) and is considered a net addition to
atmospheric CO, when combusted. In contrast, biogenic
carbon is derived from biomass sources that remove CO, from
the atmosphere during growth. When bio-based fuels are
combusted, the resulting CO, emissions are generally
considered carbon neutral, as they are offset by previously
absorbed atmospheric carbon. Biogenic CO; emissions
released during specific processes (such as ethanol
fermentation) are treated as zero-emission. This treatment
aligns with widely accepted LCA conventions and carbon
accounting protocols. However, when presenting vehicle
operation emissions, GREET explicitly shows biofuel
combustion CO; emissions to allow comparison across fuels. In




this case, an equivalent biogenic CO, creditis applied in the
feedstock stage to reflect atmospheric carbon uptake.

For e-fuels or fuels produced through CO, utilization
technologies, R&D GREET treats combustion emissions of e-
fuels as carbon neutral regardless of the original CO, source.
This is based on the assumption that the CO, used for fuel
production would otherwise be emitted from the first sources to
the atmosphere. Thus, R&D GREET credits e-fuel systems with
avoided emissions.

Terminology

Feedstock Stage: life-cycle stage associated with feedstock production, feedstock
transportation, and feedstock storage

Fuel Stage: life-cycle stage associated with fuel production, fuel transportation, fuel
distribution, and fuel storage

Well-to-Pump (WTP): life-cycle stage associated with the feedstock and fuel stages
combined

Vehicle Operation (aka Pump-to-Wheel or Pump-to-Wake or PTW): life-cycle stage
associated with fuel combustion, fuel conversion, fuel evaporation, and tire/brake wear

Well-to-Wheel (WTW): WTP and vehicle operation combined

Vehicle Cycle: life-cycle stage associated with raw material recovery, material processing
and fabrication, vehicle component production, vehicle assembly, recycling, and disposal

Cradle-to-Grave (C2G): WTP, vehicle operation, and vehicle cycle combined

Urban Emissions: the emissions produced throughout the life cycle that only occur within
the boundaries of a given metropolitan area

Lower Heating Values: thermal energy produced by the combustion of a fuel, not
incorporating the latent heat of vaporization of water produced during the combustion
process. By default, GREET uses lower heating values

Higher Heating Values: thermal energy produced by the combustion of a fuel, incorporating
the latent heat of vaporization of water produced during the combustion process




